How to Install 389 Directory Server on CentOS 5.8

Share this Article :

389 Directory Server is an enterprise-class open source LDAP server for Linux and it’s based on Fedora Directory Server.This post will show you the quick steps to install 389 Directory Server on linux CentOS 5.8 server using EPEL repository. This post assumed that your CentOS server has been completely installed with minimum packages and the hostname and FQDN also has been configured correctly. Please make sure that you have configured EPEL repository on your CentOS 5.8 server.

Prerequisites :
How to Setup Local Yum Repository from CD-ROM/DVD-ROM image on CentOS 5.8
How to Install and Configure EPEL Repository on CentOS 5.8

Simply run this command to install 389 Directory Server on linux CentOS 5.8 server :

[[email protected] ~]# yum install 389-ds openldap-clients -y

Examples :

[[email protected] ~]# yum install 389-ds openldap-clients -y
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirror.oscc.org.my
 * epel: madura.idrepo.or.id
 * extras: mirror.oscc.org.my
 * rpmforge: mirror.oscc.org.my
 * updates: mirror.oscc.org.my
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package 389-ds.noarch 0:1.2.1-1.el5 set to be updated
--> Processing Dependency: 389-ds-console for package: 389-ds
--> Processing Dependency: 389-ds-console-doc for package: 389-ds
--> Processing Dependency: 389-admin-console-doc for package: 389-ds
--> Processing Dependency: 389-ds-base for package: 389-ds
--> Processing Dependency: 389-admin-console for package: 389-ds
--> Processing Dependency: 389-admin for package: 389-ds
--> Processing Dependency: idm-console-framework for package: 389-ds
--> Processing Dependency: 389-dsgw for package: 389-ds
--> Processing Dependency: 389-console for package: 389-ds
---> Package openldap-clients.i386 0:2.3.43-25.el5 set to be updated
--> Running transaction check
---> Package 389-admin.i386 0:1.1.29-1.el5 set to be updated
--> Processing Dependency: perl-Mozilla-LDAP for package: 389-admin
--> Processing Dependency: perl(Mozilla::LDAP::Utils) for package: 389-admin
--> Processing Dependency: perl(Mozilla::LDAP::Conn) for package: 389-admin
--> Processing Dependency: perl(Mozilla::LDAP::API) for package: 389-admin
--> Processing Dependency: nss-tools for package: 389-admin
--> Processing Dependency: mod_nss for package: 389-admin
--> Processing Dependency: libssldap60.so for package: 389-admin
--> Processing Dependency: libprldap60.so for package: 389-admin
--> Processing Dependency: libldif60.so for package: 389-admin
--> Processing Dependency: libldap60.so for package: 389-admin
--> Processing Dependency: libadmsslutil.so.0 for package: 389-admin
--> Processing Dependency: libadminutil.so.0 for package: 389-admin
---> Package 389-admin-console.noarch 0:1.1.8-1.el5 set to be updated
---> Package 389-admin-console-doc.noarch 0:1.1.8-1.el5 set to be updated
---> Package 389-console.noarch 0:1.1.7-3.el5 set to be updated
--> Processing Dependency: java >= 1:1.6.0 for package: 389-console
--> Processing Dependency: jpackage-utils for package: 389-console
---> Package 389-ds-base.i386 0:1.2.9.9-1.el5 set to be updated
--> Processing Dependency: 389-ds-base-libs = 1.2.9.9-1.el5 for package: 389-ds-base
--> Processing Dependency: libslapd.so.0 for package: 389-ds-base
--> Processing Dependency: cyrus-sasl-gssapi for package: 389-ds-base
--> Processing Dependency: cyrus-sasl-md5 for package: 389-ds-base
--> Processing Dependency: libsvrcore.so.0 for package: 389-ds-base
--> Processing Dependency: db4-utils for package: 389-ds-base
--> Processing Dependency: mozldap-tools for package: 389-ds-base
---> Package 389-ds-console.noarch 0:1.2.6-1.el5 set to be updated
---> Package 389-ds-console-doc.noarch 0:1.2.6-1.el5 set to be updated
---> Package 389-dsgw.i386 0:1.1.9-1.el5 set to be updated
---> Package idm-console-framework.noarch 0:1.1.7-5.el5 set to be updated
--> Processing Dependency: jss >= 4.2 for package: idm-console-framework
--> Processing Dependency: ldapjdk for package: idm-console-framework
--> Running transaction check
---> Package 389-adminutil.i386 0:1.1.15-1.el5 set to be updated
---> Package 389-ds-base-libs.i386 0:1.2.9.9-1.el5 set to be updated
---> Package cyrus-sasl-gssapi.i386 0:2.1.22-5.el5_4.3 set to be updated
---> Package cyrus-sasl-md5.i386 0:2.1.22-5.el5_4.3 set to be updated
---> Package db4-utils.i386 0:4.3.29-10.el5_5.2 set to be updated
---> Package java-1.6.0-openjdk.i386 1:1.6.0.0-1.25.1.10.6.el5_8 set to be updated
--> Processing Dependency: libasound.so.2(ALSA_0.9.0rc4) for package: java-1.6.0-openjdk
--> Processing Dependency: libasound.so.2 for package: java-1.6.0-openjdk
--> Processing Dependency: libgif.so.4 for package: java-1.6.0-openjdk
--> Processing Dependency: libXtst.so.6 for package: java-1.6.0-openjdk
--> Processing Dependency: libasound.so.2(ALSA_0.9) for package: java-1.6.0-openjdk
--> Processing Dependency: tzdata-java for package: java-1.6.0-openjdk
---> Package jpackage-utils.noarch 0:1.7.3-1jpp.2.el5 set to be updated
---> Package jss.i386 0:4.2.6-6.el5.centos set to be updated
---> Package ldapjdk.i386 0:4.18-2jpp.3.el5 set to be updated
--> Processing Dependency: java-gcj-compat for package: ldapjdk
--> Processing Dependency: libgcj_bc.so.1 for package: ldapjdk
---> Package mod_nss.i386 0:1.0.8-4.el5_6.1 set to be updated
---> Package mozldap.i386 0:6.0.5-1.el5 set to be updated
---> Package mozldap-tools.i386 0:6.0.5-1.el5 set to be updated
---> Package nss-tools.i386 0:3.13.1-5.el5_8 set to be updated
--> Processing Dependency: nss = 3.13.1-5.el5_8 for package: nss-tools
--> Processing Dependency: libnssutil3.so(NSSUTIL_3.13) for package: nss-tools
--> Processing Dependency: libnss3.so(NSS_3.13) for package: nss-tools
---> Package perl-Mozilla-LDAP.i386 0:1.5.2-4.el5 set to be updated
---> Package svrcore.i386 0:4.0.4-3.el5 set to be updated
--> Running transaction check
---> Package alsa-lib.i386 0:1.0.17-1.el5 set to be updated
---> Package giflib.i386 0:4.1.3-7.3.3.el5 set to be updated
---> Package java-1.4.2-gcj-compat.i386 0:1.4.2.0-40jpp.115 set to be updated
base/filelists                                                               | 3.0 MB     00:27
epel/filelists_db                                                            | 4.7 MB     00:44
extras/filelists_db                                                          | 213 kB     00:01
rpmforge/filelists_db                                                        | 6.0 MB     00:57
updates/filelists_db                                                         | 1.2 MB     00:10
--> Processing Dependency: zip for package: java-1.4.2-gcj-compat
--> Processing Dependency: gjdoc for package: java-1.4.2-gcj-compat
---> Package libXtst.i386 0:1.0.1-3.1 set to be updated
---> Package libgcj.i386 0:4.1.2-52.el5_8.1 set to be updated
--> Processing Dependency: libart_lgpl >= 2.1.0 for package: libgcj
--> Processing Dependency: libICE.so.6 for package: libgcj
--> Processing Dependency: libSM.so.6 for package: libgcj
---> Package nss.i386 0:3.13.1-5.el5_8 set to be updated
--> Processing Dependency: nspr >= 4.8.9 for package: nss
---> Package tzdata-java.i386 0:2012b-3.el5 set to be updated
--> Running transaction check
---> Package gjdoc.i386 0:0.7.7-12.el5 set to be updated
--> Processing Dependency: antlr for package: gjdoc
---> Package libICE.i386 0:1.0.1-2.1 set to be updated
---> Package libSM.i386 0:1.0.1-3.1 set to be updated
---> Package libart_lgpl.i386 0:2.3.17-4 set to be updated
---> Package nspr.i386 0:4.8.9-1.el5_8 set to be updated
---> Package zip.i386 0:2.31-2.el5 set to be updated
--> Running transaction check
---> Package antlr.i386 0:2.7.6-4jpp.2 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

====================================================================================================
 Package                  Arch      Version                           Repository               Size
====================================================================================================
Installing:
 389-ds                   noarch    1.2.1-1.el5                       epel                    9.1 k
 openldap-clients         i386      2.3.43-25.el5                     CentOS5.8-Repository    218 k
Installing for dependencies:
 389-admin                i386      1.1.29-1.el5                      epel                    412 k
 389-admin-console        noarch    1.1.8-1.el5                       epel                    203 k
 389-admin-console-doc    noarch    1.1.8-1.el5                       epel                     40 k
 389-adminutil            i386      1.1.15-1.el5                      epel                     70 k
 389-console              noarch    1.1.7-3.el5                       epel                     72 k
 389-ds-base              i386      1.2.9.9-1.el5                     epel                    1.6 M
 389-ds-base-libs         i386      1.2.9.9-1.el5                     epel                    407 k
 389-ds-console           noarch    1.2.6-1.el5                       epel                    1.4 M
 389-ds-console-doc       noarch    1.2.6-1.el5                       epel                     55 k
 389-dsgw                 i386      1.1.9-1.el5                       epel                    1.1 M
 alsa-lib                 i386      1.0.17-1.el5                      base                    412 k
 antlr                    i386      2.7.6-4jpp.2                      base                    978 k
 cyrus-sasl-gssapi        i386      2.1.22-5.el5_4.3                  base                     29 k
 cyrus-sasl-md5           i386      2.1.22-5.el5_4.3                  base                     46 k
 db4-utils                i386      4.3.29-10.el5_5.2                 base                    119 k
 giflib                   i386      4.1.3-7.3.3.el5                   base                     39 k
 gjdoc                    i386      0.7.7-12.el5                      base                    793 k
 idm-console-framework    noarch    1.1.7-5.el5                       epel                    1.1 M
 java-1.4.2-gcj-compat    i386      1.4.2.0-40jpp.115                 base                     29 k
 java-1.6.0-openjdk       i386      1:1.6.0.0-1.25.1.10.6.el5_8       updates                  37 M
 jpackage-utils           noarch    1.7.3-1jpp.2.el5                  base                     61 k
 jss                      i386      4.2.6-6.el5.centos                extras                  694 k
 ldapjdk                  i386      4.18-2jpp.3.el5                   base                    782 k
 libICE                   i386      1.0.1-2.1                         base                     54 k
 libSM                    i386      1.0.1-3.1                         base                     27 k
 libXtst                  i386      1.0.1-3.1                         base                     15 k
 libart_lgpl              i386      2.3.17-4                          base                     76 k
 libgcj                   i386      4.1.2-52.el5_8.1                  updates                  16 M
 mod_nss                  i386      1.0.8-4.el5_6.1                   base                     86 k
 mozldap                  i386      6.0.5-1.el5                       base                    132 k
 mozldap-tools            i386      6.0.5-1.el5                       base                    139 k
 nss-tools                i386      3.13.1-5.el5_8                    updates                 1.1 M
 perl-Mozilla-LDAP        i386      1.5.2-4.el5                       base                    181 k
 svrcore                  i386      4.0.4-3.el5                       base                     14 k
 tzdata-java              i386      2012b-3.el5                       updates                 181 k
 zip                      i386      2.31-2.el5                        base                    127 k
Updating for dependencies:
 nspr                     i386      4.8.9-1.el5_8                     updates                 121 k
 nss                      i386      3.13.1-5.el5_8                    updates                 1.1 M
.
.
.
.
  Updating       : nspr                                                                        1/42
  Updating       : nss                                                                         2/42
  Installing     : svrcore                                                                     3/42
  Installing     : mozldap                                                                     4/42
  Installing     : perl-Mozilla-LDAP                                                           5/42
  Installing     : nss-tools                                                                   6/42
  Installing     : 389-adminutil                                                               7/42
  Installing     : zip                                                                         8/42
  Installing     : libICE                                                                      9/42
  Installing     : libXtst                                                                    10/42
  Installing     : alsa-lib                                                                   11/42
  Installing     : libSM                                                                      12/42
  Installing     : mod_nss                                                                    13/42
  Installing     : mozldap-tools                                                              14/42
  Installing     : 389-ds-base-libs                                                           15/42
  Installing     : db4-utils                                                                  16/42
  Installing     : cyrus-sasl-md5                                                             17/42
  Installing     : giflib                                                                     18/42
  Installing     : cyrus-sasl-gssapi                                                          19/42
  Installing     : 389-ds-base                                                                20/42
  Installing     : 389-admin                                                                  21/42
  Installing     : 389-dsgw                                                                   22/42
  Installing     : libart_lgpl                                                                23/42
  Installing     : libgcj                                                                     24/42
  Installing     : openldap-clients                                                           25/42
  Installing     : jpackage-utils                                                             26/42
  Installing     : 389-ds-console                                                             27/42
  Installing     : 389-admin-console                                                          28/42
  Installing     : 389-admin-console-doc                                                      29/42
  Installing     : 389-ds-console-doc                                                         30/42
  Installing     : tzdata-java                                                                31/42
  Installing     : java-1.6.0-openjdk                                                         32/42
  Installing     : jss                                                                        33/42
  Installing     : java-1.4.2-gcj-compat                                                      34/42
  Installing     : ldapjdk                                                                    35/42
  Installing     : gjdoc                                                                      36/42
  Installing     : antlr                                                                      37/42
  Installing     : idm-console-framework                                                      38/42
  Installing     : 389-console                                                                39/42
  Installing     : 389-ds                                                                     40/42
  Cleanup        : nspr                                                                       41/42
  Cleanup        : nss                                                                        42/42

Leave a Reply