How to Install VMware Tools on CentOS 6.4

Related Articles

vmware-toolsThis post provides steps to install VMware Tools in CentOS 6.4. It is very important to install VMware Tools in the guest operating system. Without the VMware Tools, guest OS performance will lacks some of the important functionality. VMware Tools is a group of utilities that enhances the overall performance of the virtual machine’s guest operating system (OS) and improves management of the virtual machine (VM). This is one of important components in order to provide perfect VM OS.

1. Choose your VM –> Click “Install VMware Tools” from the VMware Workstation menu, VMware Workstation temporarily connects the virtual machine’s first virtual CD-ROM drive to the ISO image file that contains the VMware Tools installer for your guest operating system and you are ready to begin the installation process.

2. Install prerequisites :

[root@centos64 ~]# yum install perl gcc make -y

Example :

[root@centos64 ~]# yum install perl gcc make -y
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: centos.ipserverone.com
 * extras: centos.ipserverone.com
 * updates: centos.ipserverone.com
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package gcc.x86_64 0:4.4.7-3.el6 will be installed
--> Processing Dependency: libgomp = 4.4.7-3.el6 for package: gcc-4.4.7-3.el6.x86_64
--> Processing Dependency: cpp = 4.4.7-3.el6 for package: gcc-4.4.7-3.el6.x86_64
--> Processing Dependency: glibc-devel >= 2.2.90-12 for package: gcc-4.4.7-3.el6.x86_64
--> Processing Dependency: cloog-ppl >= 0.15 for package: gcc-4.4.7-3.el6.x86_64
--> Processing Dependency: libgomp.so.1()(64bit) for package: gcc-4.4.7-3.el6.x86_64
---> Package make.x86_64 1:3.81-20.el6 will be installed
---> Package perl.x86_64 4:5.10.1-129.el6 will be installed
--> Processing Dependency: perl-libs = 4:5.10.1-129.el6 for package: 4:perl-5.10.1-129.el6.x86_64
--> Processing Dependency: perl-libs for package: 4:perl-5.10.1-129.el6.x86_64
--> Processing Dependency: perl(version) for package: 4:perl-5.10.1-129.el6.x86_64
--> Processing Dependency: perl(Pod::Simple) for package: 4:perl-5.10.1-129.el6.x86_64
--> Processing Dependency: perl(Module::Pluggable) for package: 4:perl-5.10.1-129.el6.x86_64
--> Processing Dependency: libperl.so()(64bit) for package: 4:perl-5.10.1-129.el6.x86_64
--> Running transaction check
---> Package cloog-ppl.x86_64 0:0.15.7-1.2.el6 will be installed
--> Processing Dependency: libppl_c.so.2()(64bit) for package: cloog-ppl-0.15.7-1.2.el6.x86_64
--> Processing Dependency: libppl.so.7()(64bit) for package: cloog-ppl-0.15.7-1.2.el6.x86_64
---> Package cpp.x86_64 0:4.4.7-3.el6 will be installed
--> Processing Dependency: libmpfr.so.1()(64bit) for package: cpp-4.4.7-3.el6.x86_64
---> Package glibc-devel.x86_64 0:2.12-1.107.el6 will be installed
--> Processing Dependency: glibc-headers = 2.12-1.107.el6 for package: glibc-devel-2.12-1.107.el6.x86_64
--> Processing Dependency: glibc-headers for package: glibc-devel-2.12-1.107.el6.x86_64
---> Package libgomp.x86_64 0:4.4.7-3.el6 will be installed
---> Package perl-Module-Pluggable.x86_64 1:3.90-129.el6 will be installed
---> Package perl-Pod-Simple.x86_64 1:3.13-129.el6 will be installed
--> Processing Dependency: perl(Pod::Escapes) >= 1.04 for package: 1:perl-Pod-Simple-3.13-129.el6.x86_64
---> Package perl-libs.x86_64 4:5.10.1-129.el6 will be installed
---> Package perl-version.x86_64 3:0.77-129.el6 will be installed
--> Running transaction check
---> Package glibc-headers.x86_64 0:2.12-1.107.el6 will be installed
--> Processing Dependency: kernel-headers >= 2.2.1 for package: glibc-headers-2.12-1.107.el6.x86_64
--> Processing Dependency: kernel-headers for package: glibc-headers-2.12-1.107.el6.x86_64
---> Package mpfr.x86_64 0:2.4.1-6.el6 will be installed
---> Package perl-Pod-Escapes.x86_64 1:1.04-129.el6 will be installed
---> Package ppl.x86_64 0:0.10.2-11.el6 will be installed
--> Running transaction check
---> Package kernel-headers.x86_64 0:2.6.32-358.2.1.el6 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

==============================================================================================================
 Package                          Arch              Version                          Repository          Size
==============================================================================================================
Installing:
 gcc                              x86_64            4.4.7-3.el6                      base                10 M
 make                             x86_64            1:3.81-20.el6                    base               389 k
 perl                             x86_64            4:5.10.1-129.el6                 base                10 M
Installing for dependencies:
 cloog-ppl                        x86_64            0.15.7-1.2.el6                   base                93 k
 cpp                              x86_64            4.4.7-3.el6                      base               3.7 M
 glibc-devel                      x86_64            2.12-1.107.el6                   base               974 k
 glibc-headers                    x86_64            2.12-1.107.el6                   base               604 k
 kernel-headers                   x86_64            2.6.32-358.2.1.el6               updates            2.3 M
 libgomp                          x86_64            4.4.7-3.el6                      base               118 k
 mpfr                             x86_64            2.4.1-6.el6                      base               157 k
 perl-Module-Pluggable            x86_64            1:3.90-129.el6                   base                38 k
 perl-Pod-Escapes                 x86_64            1:1.04-129.el6                   base                31 k
 perl-Pod-Simple                  x86_64            1:3.13-129.el6                   base               210 k
 perl-libs                        x86_64            4:5.10.1-129.el6                 base               576 k
 perl-version                     x86_64            3:0.77-129.el6                   base                50 k
 ppl                              x86_64            0.10.2-11.el6                    base               1.3 M

Transaction Summary
==============================================================================================================
Install      16 Package(s)

Total download size: 31 M
Installed size: 75 M
Downloading Packages:
(1/16): cloog-ppl-0.15.7-1.2.el6.x86_64.rpm                                            |  93 kB     00:01
(2/16): cpp-4.4.7-3.el6.x86_64.rpm                                                     | 3.7 MB     00:36
(3/16): gcc-4.4.7-3.el6.x86_64.rpm                                                     |  10 MB     01:36
(4/16): glibc-devel-2.12-1.107.el6.x86_64.rpm                                          | 974 kB     00:08
(5/16): glibc-headers-2.12-1.107.el6.x86_64.rpm                                        | 604 kB     00:10
(6/16): kernel-headers-2.6.32-358.2.1.el6.x86_64.rpm                                   | 2.3 MB     00:23
(7/16): libgomp-4.4.7-3.el6.x86_64.rpm                                                 | 118 kB     00:00
(8/16): make-3.81-20.el6.x86_64.rpm                                                    | 389 kB     00:03
(9/16): mpfr-2.4.1-6.el6.x86_64.rpm                                                    | 157 kB     00:01
(10/16): perl-5.10.1-129.el6.x86_64.rpm                                                |  10 MB     01:40
(11/16): perl-Module-Pluggable-3.90-129.el6.x86_64.rpm                                 |  38 kB     00:00
(12/16): perl-Pod-Escapes-1.04-129.el6.x86_64.rpm                                      |  31 kB     00:00
(13/16): perl-Pod-Simple-3.13-129.el6.x86_64.rpm                                       | 210 kB     00:02
(14/16): perl-libs-5.10.1-129.el6.x86_64.rpm                                           | 576 kB     00:05
(15/16): perl-version-0.77-129.el6.x86_64.rpm                                          |  50 kB     00:00
(16/16): ppl-0.10.2-11.el6.x86_64.rpm                                                  | 1.3 MB     00:11
--------------------------------------------------------------------------------------------------------------
Total                                                                         103 kB/s |  31 MB     05:06
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing : 1:perl-Pod-Escapes-1.04-129.el6.x86_64                                                    1/16
  Installing : 4:perl-libs-5.10.1-129.el6.x86_64                                                         2/16
  Installing : 3:perl-version-0.77-129.el6.x86_64                                                        3/16
  Installing : 1:perl-Module-Pluggable-3.90-129.el6.x86_64                                               4/16
  Installing : 1:perl-Pod-Simple-3.13-129.el6.x86_64                                                     5/16
  Installing : 4:perl-5.10.1-129.el6.x86_64                                                              6/16
  Installing : ppl-0.10.2-11.el6.x86_64                                                                  7/16
  Installing : cloog-ppl-0.15.7-1.2.el6.x86_64                                                           8/16
  Installing : kernel-headers-2.6.32-358.2.1.el6.x86_64                                                  9/16
  Installing : glibc-headers-2.12-1.107.el6.x86_64                                                      10/16
  Installing : glibc-devel-2.12-1.107.el6.x86_64                                                        11/16
  Installing : libgomp-4.4.7-3.el6.x86_64                                                               12/16
  Installing : mpfr-2.4.1-6.el6.x86_64                                                                  13/16
  Installing : cpp-4.4.7-3.el6.x86_64                                                                   14/16
  Installing : gcc-4.4.7-3.el6.x86_64                                                                   15/16
  Installing : 1:make-3.81-20.el6.x86_64                                                                16/16
  Verifying  : glibc-devel-2.12-1.107.el6.x86_64                                                         1/16
  Verifying  : gcc-4.4.7-3.el6.x86_64                                                                    2/16
  Verifying  : 1:perl-Pod-Escapes-1.04-129.el6.x86_64                                                    3/16
  Verifying  : 1:perl-Pod-Simple-3.13-129.el6.x86_64                                                     4/16
  Verifying  : mpfr-2.4.1-6.el6.x86_64                                                                   5/16
  Verifying  : libgomp-4.4.7-3.el6.x86_64                                                                6/16
  Verifying  : 4:perl-5.10.1-129.el6.x86_64                                                              7/16
  Verifying  : 4:perl-libs-5.10.1-129.el6.x86_64                                                         8/16
  Verifying  : cpp-4.4.7-3.el6.x86_64                                                                    9/16
  Verifying  : 1:make-3.81-20.el6.x86_64                                                                10/16
  Verifying  : 3:perl-version-0.77-129.el6.x86_64                                                       11/16
  Verifying  : 1:perl-Module-Pluggable-3.90-129.el6.x86_64                                              12/16
  Verifying  : kernel-headers-2.6.32-358.2.1.el6.x86_64                                                 13/16
  Verifying  : ppl-0.10.2-11.el6.x86_64                                                                 14/16
  Verifying  : cloog-ppl-0.15.7-1.2.el6.x86_64                                                          15/16
  Verifying  : glibc-headers-2.12-1.107.el6.x86_64                                                      16/16

Installed:
  gcc.x86_64 0:4.4.7-3.el6          make.x86_64 1:3.81-20.el6          perl.x86_64 4:5.10.1-129.el6

Dependency Installed:
  cloog-ppl.x86_64 0:0.15.7-1.2.el6                     cpp.x86_64 0:4.4.7-3.el6
  glibc-devel.x86_64 0:2.12-1.107.el6                   glibc-headers.x86_64 0:2.12-1.107.el6
  kernel-headers.x86_64 0:2.6.32-358.2.1.el6            libgomp.x86_64 0:4.4.7-3.el6
  mpfr.x86_64 0:2.4.1-6.el6                             perl-Module-Pluggable.x86_64 1:3.90-129.el6
  perl-Pod-Escapes.x86_64 1:1.04-129.el6                perl-Pod-Simple.x86_64 1:3.13-129.el6
  perl-libs.x86_64 4:5.10.1-129.el6                     perl-version.x86_64 3:0.77-129.el6
  ppl.x86_64 0:0.10.2-11.el6

Complete!

3. Reboot VM.

[root@centos64 ~]# reboot

4. Mount the installer.

[root@centos64 ~]# mount -t iso9660 /dev/cdrom /mnt
mount: block device /dev/sr0 is write-protected, mounting read-only

5. Copy the installer to /tmp :

[root@centos64 ~]# cd /mnt
[root@centos64 mnt]# cp VMwareTools-9.2.2-893683.tar.gz /tmp

6. Extract the installer :

[root@centos64 ~]# cd /tmp
[root@centos64 tmp]# tar xzvf VMwareTools-9.2.2-893683.tar.gz

7. Enter the vmware-tools-distrib directory :

[root@centos64 tmp]# cd vmware-tools-distrib/

8. Install the VMware Tools :

[root@centos64 vmware-tools-distrib]# ./vmware-install.pl
As always if you need any help you can reach us on twitter @ehowstuff or drop us a comment below. Jumping through archives page to read more articles..


Skytech is a part time blogger that has over 6 years experience in servicing, repairing and configuring computers and administering the server systems.

Related Articles

Powered by WordPress · Designed by Theme Junkie